请选择 进入手机版 | 继续访问电脑版

运维工作室

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
热搜: 活动 交友 discuz
查看: 3113|回复: 0

CentOS 6.5升级Glibc 2.14

[复制链接]

34

主题

34

帖子

213

积分

中级会员

Rank: 3Rank: 3

积分
213
发表于 2015-7-23 16:30:28 | 显示全部楼层 |阅读模式
由于编译某些程序需要用到glibc-2.14,但是centOS6.4上没有所以需要自己安装。以下介绍安装升级过程:
1、下载
cd /usr/local/src
# mkdir glibc-bulid
# cd glibc-bulid/
# wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz
# wget http://ftp.gnu.org/gnu/glibc/glibc-linuxthreads-2.5.tar.bz2
2、编译安装
# tar zxf glibc-2.14.tar.gz
# cd glibc-2.14
# tar jxf ../glibc-linuxthreads-2.5.tar.bz2
# cd ../                           //进上一级编译,否则出错
# ./glibc-2.14/configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
# make
# make install

检验是否成功
# ls -l /lib64/libc.so.6     
lrwxrwxrwx 1 root root 12 Jul 23 16:17 /lib64/libc.so.6 -> libc-2.14.so

最后会遇到一个报错,不影响。
/usr/bin/ld: cannot find -lnss_test1
collect2: ld returned 1 exit status
Execution of gcc -B/usr/bin/ failed!

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|bbs.go-news.com  

GMT+8, 2018-6-25 21:15 , Processed in 0.093382 second(s), 24 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表